exp/imp

EXP / IMP has a quite a lot of bugs and limitations.

Today I had a trouble with a function based index first, generating ORA-942 table does not exist on import. I also had an error with AQ.

I have a few invalid objects too :

before exp, on source system (tru64/9.2.0.4)

SQL> select count(*) from dba_objects where status='INVALID';
 
  COUNT(*)
----------
        54

after imp, on target system (rh4/10.2.0.2)

SQL> select count(*) from dba_objects where status='INVALID';
 
  COUNT(*)
----------
    142240

let’s recompile

SQL> @?/rdbms/admin/utlrp

SQL> select count(*) from dba_objects where status='INVALID';
 
  COUNT(*)
----------
      2699

… better, but still too much !

I probably did hit bug 3169196 too. The workaround is delicious :

<b>manually clean the data dictionary</b>

Well, I am going to drop the destination database and try again…

2 thoughts on “exp/imp”

  1. I also like the status:
    Severity Severe Loss of Service Status Not a Bug. To Filer

  2. If I recall correctly we had a problem with AQs – you can’t import an AQ twice in the same database or in the same database as source but in different schema because there is some specific ID that is unique instance-wide and you get ORA-00001 on import. This is relevant to 9iR2 – no idea about others.
    In fact, I hate AQ’s but this is another story… :)

Leave a Reply

Your email address will not be published.


*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>